Supported Platforms

This topic lists the supported Windows, Mac and Unix/Linux platforms on which you can install the following ObserveIT components:

  • Windows Agent

  • Unix/Linux Agent

  • Mac Agent

  • Application Server

  • Web Console

  • Database Server

For details about the minimum system requirements for each ObserveIT component, see System Requirements for ObserveIT Components.

  • Debian 9

Windows Agent

You can deploy ObserveIT Agents on the following Microsoft Windows operating systems:

  • Windows 10 (32-bit and 64-bit)

  • Windows 8.1 (32-bit and 64-bit)

  • Windows Server 2016 (64-bit only)

  • Windows Server 2012 R2 (64-bit only)

  • Windows Server 2012 (64-bit only)

  • Windows Server 2019 (64-bit only)

  • Win 10 Enterprise Multi-Session

  • Windows Virtual Desktop Win10

  • Win 10 V1903,V1909, V2004

Citrix XenApp and Citrix XenDesktop 5.x, 6.x, and 7.x (up to and including 7.15) environments are also supported.

Supporting Earlier Windows Versions

  • Windows Server 2008 supported for ObserveIT Agents up to 7.9.1 on best effort.
  • Windows 7.0 with .NET 4.72 supported for ObserveIT Agents up to 7.9.1 on best effort (Windows 7.0 with .NET 3.5 is not supported).

Unix/Linux Agent

Solaris "Whole Root" Zones are supported; you should install an ObserveIT Agent in each zone.

Solaris "Sparse" Zones are not supported.

You can deploy ObserveIT Agents on the following Unix/Linux-based operating systems:

  • Solaris 11, updates 1-4; x86/x64 or Sparc

  • Solaris 10, updates 7-11; x86/x64 or Sparc

  • RHEL/CentOS 8.3

  • RHEL/CentOS 8.2

  • RHEL/CentOS 7.X

  • RHEL/CentOS 6.7-6.10

  • Oracle Linux 8-8.2

  • Oracle Linux 7.0-7.4 x86_64

  • Oracle Linux 7.8

  • Oracle Linux 6.7-6.10 i386/x86_64

  • SLES SuSE 15.2 32 & 64 bit

  • SLES SuSE 12 i386/x86_64

  • SLES SuSE 11 - 32 & 64 bit

  • Ubuntu 20.04 LTS i386/x86_64

  • Ubuntu 18.04 LTS i386/x86_64

  • Ubuntu 16.04 LTS i386/x86_64

  • Ubuntu 14.04 LTS i386/x86_64

  • AIX 7.2 32-bit/64-bit

  • AIX 7.1 32-bit/64-bit

  • HP-UX 11.31 Itanium architecture (64-bit)

  • Debian 8. 9 and 10 32-bit/64-bit

  • Amazon Linux AMI 2015.03, 2017.09

  • Amazon Linux 2

Supporting Earlier Unix/Linux Versions

  • Solaris 10 with OpenSSL version 0.9.7/0.9.8 is supported ONLY for ObserveIT Agents up to 6.7.2 on best effort.
  • HP-UX 11.23 Itanium architecture (64-bit) is supported for ObserveIT Agents up to 6.7.0 on best effort.
  • RHEL/CentOS 4.8-4.9 i386/x86_64 is supported ONLY for ObserveIT Agents up to 7.6.2 on best effort.
  • OSX 10.10 and 10.11 are supported ONLY for ObserveIT Agents up to 7.6.2 on best effort.
  • Debian 6 32-bit/64-bit is supported ONLY for ObserveIT Agents up to 7.6.2 on best effort.

Mac Agent

The following versions are supported for deploying ObserveIT Agents on a Mac-based desktop, laptop, or server:

  • macOS Big Sur 11

  • macOS Catalina 10.15

  • macOS Mojave 10.14

Supporting Earlier macOS Versions

  • macOS Sierra 10.12 supported from ObserveIT 7.9.x on best effort only
  • macOS High Sierra 10.13 supported from ObserveIT 7.10.x on best effort only
  • macOS Yosemite 10.10 and macOS El Capitan 10.11 supported ONLY for ObserveIT Agents up to 7.6.2 on best effort.

Application Server

The ObserveIT Application Server is implemented as an ASP.NET Web application that runs on Microsoft Internet Information Server (IIS) 8.0 or higher. You can deploy the ObserveIT Application Server on the following Microsoft Windows-based operating systems. It is recommended that you always use the latest Service Pack for your operating system.

  • Windows Server 2019 (64-bit only)\

  • Windows Server 2016 (64-bit only)

  • Windows Server 2012 R2 (64-bit only)

  • Windows Server 2012 (64-bit only)

Web Console

The ObserveIT Web Console is implemented as an ASP.NET Web application that runs on Microsoft Internet Information Server (IIS). You can deploy the ObserveIT Web Console on the following Microsoft Windows-based operating systems. It is recommended that you always use the latest Service Pack for your operating system.

  • Windows Server 2019 (64-bit only)

  • Windows Server 2016 (64-bit only)

  • Windows Server 2012 R2 (64-bit only)

  • Windows Server 2012 (64-bit only)

Following are the supported Web Browsers for the ObserveIT Web Console:

Web Browser

Supported Versions

Mozilla Firefox

31 and higher

Google Chrome

36 and higher

Microsoft Edge for Windows 10

25 and higher

Microsoft Edge Chromium for Windows 10 83 and higher

Database Server

The ObserveIT Database Server requires one of the following SQL Server versions with the latest Service Pack:

  • Microsoft SQL Server 2019

  • Microsoft SQL Server 2017

  • Microsoft SQL Server 2016

  • Microsoft SQL Server 2014 (Enterprise only)

  • Microsoft SQL Server 2012 (Enterprise only)

Note the following:

  • Microsoft SQL Server 2008 is not supported from version 7.5 and up.

  • SQL Server Express edition is not supported for production environments. It is recommended that you use a regular full-featured version of SQL Server, since the SQL Server Express edition has database size limitations and other restrictions that make it unsuitable for production environments.

  • If planning to use data encryption, plan for CPU overhead.

  • If you plan to use the archiving feature of ObserveIT, make sure that you have available at least twice the disk space expected for the archived data.

  • It is recommended that you use Mixed Authentication instead of Windows Authentication.

Backward Compatibility - Minimum Supported Versions and Upgrade Requirements

Most features, functions, and capabilities of ObserveIT 7.11.2 are compatible with earlier versions of the ObserveIT Agent. However, you should avoid using Agents that have an earlier version than the server-side components. To maintain full feature compatibility, it is highly recommended that you upgrade your Agents to the most current version of the product.

Following are the minimum server-side and Agent components versions that are supported in this release:

Component

Minimum Supported Version

Upgrade Requirements

Server-side

ObserveIT 7.6.4 is the minimum supported version that can be upgraded to 7.11.2.

From ObserveIT 7.1, support is on best effort.

If you have an earlier version that is not supported, first upgrade to the minimum supported version, and then upgrade to the latest version.

Agents (Windows or Unix)

ObserveIT 7.6.4 is the minimum supported version for Agents to be upgraded to 7.11.2 (backward compatibility of Agents).

If you have an earlier version that is not supported, uninstall it, and then install the latest version.

version 7.11.2