Proofpoint | ObserveIT On-Premises Insider Threat Management

Upgrading ITM On-Prem (ObserveIT)

ITM On-Prem (ObserveIT) can be easily upgraded when new versions are available.

In Production environments, it is recommended that you use the ITM On-Prem (ObserveIT) custom installation (see ITM On-Prem (ObserveIT) Custom Installation) for a clean install and for upgrading existing versions. Using the ObserveIT.Installer.exe file that is part of the installation package is not recommended.

The older version does not need to be uninstalled in order to upgrade. The installation process first upgrades the ITM On-Prem (ObserveIT) Database, then the ITM On-Prem Web Console and Application Server components, and finally, the ITM On-Prem (ObserveIT) Agent that was installed on the same machine as the one that is used to run the installation. If required, you can perform a custom upgrade of the server-side components (Web Console and Application Server) separately.

The latest version of ITM On-Prem (ObserveIT) provides improved database scalability and performance for large-scale enterprise deployments with multiple desktops and servers. After upgrading an earlier ITM On-Prem (ObserveIT) installation to this version, database performance is significantly improved.

When performing upgrades for large scale enterprises, depending on the size of the database, a number of prerequisites are required for the data migration to be successful.

Before you begin the upgrade process, it is important that you read Prerequisites for Upgrading ObserveIT.

Agents can be upgraded on Windows, Solaris, AIX, HP-UX, RHEL/CentOS, Oracle Linux, SLES (SuSE Linux enterprise Server), Ubuntu, Debian, Amazon Linux, or Mac Servers.

Most features, functions, and capabilities of ObserveIT 7.13.3 are compatible with earlier versions of the ITM On-Prem (ObserveIT) Agent. However, you should avoid using Agents that have an earlier version than the server-side components. To maintain full feature compatibility, it is highly recommended that you upgrade your Agents to the most current version of the product.

Important Notes

  • If the Full Text Search (FTS) utility of Microsoft SQL Server is not already installed, you will receive a prompt during upgrade. If you want to install the FTS module after completing the upgrade, click Yes in order to execute a script that will initialize the database to use the module. Click No to abort the upgrade.

  • To upgrade some or all of the installed Agents on Windows, see Agent Auto Upgrade. For Agents on Mac and Unix or Linux, you will need to manually perform an Agent installation on all the monitored servers and workstations.

  • The upgrade process should complete without any issues. However, because upgrading the ITM On-Prem (ObserveIT) Database involves changes to the data, make sure that you have a valid and working backup before proceeding with these steps.

  • Upgrading the components does not require a reboot of the servers, but will result in a temporary loss of recording during the upgrading process.

For more details about backward compatibility, see Upgrading Backwards Compatibility .

The following topics describe:

version 7.13.3